Development Dependencies/Fr

From The Open Source Backup Wiki (Amanda, MySQL Backup, BackupPC)

Jump to: navigation, search

Dépendances de Développement

Alors que les pré-requis en terme de run-time et build-time sont minimaux, le développement d'Amanda nécessite des versions plutôt récentes de plusieurs outils. (N.D.T.: les termes build et building de développement sont traduits soit par construire et élaborer, ou construction et élaboration)

Noter que la procédure de construction d'une distribution tar d'Amanda:

  • applique les autotools pour générer le configure;
  • applique SWIG pour construire les fichiers C nécessaires;
  • et applique Docbook pour élaborer la source manpage.

Donc, quoique ces outils sont requis pour construire depuis la source en Git ou Subversion, ils ne sont pas requis pour une construction/installation depuis un tar.

Contents

Général

Bison
>= 1.27
Noter que cela est aussi requis pour construire Amanda depuis les tars de distribution
Flex
>= 2.5.4a
Noter que cela est aussi requis pour construire Amanda depuis les tars de distribution
Glib
>= 2.2.0 (La numérotation de version de glib est ancienne. 2.13.2 est bien!)
Noter que sur certaines distributions vous aurez aussi besoin des paquets "devel"
Noter que cela est aussi requis pour construire Amanda depuis les tars de distribution
rpcgen
N'importe quelle version ira bien
Cela est requis pour ndmp; élaborer --without-ndmp évitera ce pré-requis

Autotools

Automake 
>= 1.9.6
Autoconf 
>= 2.60

SWIG

SWIG 
>= 1.3.39
SWIG-2.0.0 marche aussi
Noter que si vous utilisez MacPorts, vous aurez besoin de swig et swig-perl

Documentation

Pour élaborer la documentation (optionnel, seulement avec --enable-manpage-build):

xsltproc 
Pas de version mini connue
docbook-xsl-stylesheets 
1.72.0 ou plus
docbook-xml-dtd 
4.1.2, 4.2, et 4.4 (oui, toutes les trois)

Other languages: English  • Français


Personal tools