Development Dependencies

From The Open Source Backup Wiki (Amanda, MySQL Backup, BackupPC)

Jump to: navigation, search

While Amanda's run-time and build-time requirements are minimal, Amanda development requires fairly new versions of several tools.

Note that the process of building an Amanda distribution tarball:

  • applies the autotools to generate configure;
  • applies SWIG to build the necessary C files;
  • and applies Docbook to build the manpage source.

So while these tools are required to build from the source in Git or Subversion, they are not required to build from a tarball.

Contents

General

Bison
>= 1.27
note that this is required to build Amanda from distribution tarballs, too
Flex
>= 2.5.4a
note that this is required to build Amanda from distribution tarballs, too
Glib
>= 2.2.0 (glib version numbering is odd. 2.13.2 is fine!)
note that on some distributions you also need "devel" packages
note that this is required to build Amanda from distribution tarballs, too
rpcgen
any version will do
this is required for ndmp; building --without-ndmp will avoid the requirement

Autotools

Automake 
>= 1.9.6
Autoconf 
>= 2.60

SWIG

SWIG 
>= 1.3.39
SWIG-2.0.0 works, too
note that if you are using MacPorts, you will need both swig and swig-perl

Documentation

For building the documentation (optional, only with --enable-manpage-build):

xsltproc 
no known minimum version
docbook-xsl-stylesheets 
1.72.0 or higher
docbook-xml-dtd 
4.1.2, 4.2, and 4.4 (yes, all three)

Other languages: English  • Fran├žais


Personal tools